30 176 odsłony

svchost.exe 100% CPU?

Wie­le osób ma pro­ble­my z pro­ce­sem svchost.exe , któ­ry przy włą­czo­nych Aktu­ali­za­cjach auto­ma­tycz­nych sys­te­mu może zuży­wać do 100% CPU. Dzię­ki takie­mu zacho­wa­niu kom­pu­ter wol­no pra­cu­je i tra­ci na wydaj­no­ści. Jak sobie z tym pro­ble­mem pora­dzić? Dowiesz się tego z poniż­sze­go arty­ku­łu.

1.) Prze­cho­dzi­my na stro­nę Micro­so­ftu, aby pobrać pierw­szą potrzeb­ną łat­kę. Może­my to zro­bić kli­ka­jąc w ten odno­śnik: KLIK Pobra­ny plik zapi­su­je­my na par­ty­cji sys­te­mo­wej (naj­czę­ściej C), ale nie na pul­pi­cie:

2.) Pobie­ra­my dru­gą potrzeb­ną łat­kę: fix_svchost.bat Plik zapi­su­je­my rów­nież na par­ty­cji sys­te­mo­wej, naj­le­piej w tym samym fol­de­rze, co poprzed­nia łat­ka. Aby pobrać łat­kę kli­ka­my na odno­śnik PPM i wybie­ra­my Zapisz ele­ment doce­lo­wy jako:

3.) Na koniec pobie­ra­my ostat­nią łat­kę z witry­ny Micro­so­ftu: KLIK Plik zapi­su­je­my do kata­lo­gu z wcze­śniej­szy­mi łat­ka­mi. Po pobra­niu wszyst­kich trzech pli­ków NIE INSTALUJEMY NA RAZIE ŻADNEGO Z NICH!

4.) Łat­ki musi­my zain­sta­lo­wać w Try­bie awa­ryj­nym. W tym celu uru­cha­mia­my ponow­nie kom­pu­ter i wci­ska­my tak dłu­go kla­wisz F8, aż ujrzy­my menu wybo­ru sys­te­mów ope­ra­cyj­nych:

5.) Gdy już zała­du­je się tryb awa­ryj­ny prze­cho­dzi­my do menu START — >Uru­chom — >kli­ka­my Prze­glą­daj. Teraz odnaj­du­je­my plik fix_svchost.bat i otwie­ra­my go:

6.) Przez chwil­kę na ekra­nie czar­ne okno z tek­stem. Po chwi­li okno znik­nie. Pro­ces został akty­wo­wa­ny.

7.) Prze­cho­dzi­my zno­wu do menu Uru­chom, kli­ka­my Prze­glą­daj. Teraz wybie­ra­my pierw­szą pobra­ną łat­kę o nazwie win­dow­sup­da­te­agen­t30-x86. Aby zain­sta­lo­wać łat­kę wyko­nu­je­my kro­ki, jakie wyświe­tlą się na ekra­nie:

8.) Po zain­sta­lo­wa­niu łat­ki pora zain­sta­lo­wać ostat­nią pobra­ną: Win­dow­sXP-KB927891-v3-x86-ENU. Prze­cho­dzi­my do Uru­chom, kli­ka­my Prze­glą­daj i wska­zu­je­my potrzeb­ny plik:

9.) Gdy zain­sta­lu­je­my już wszyst­kie potrzeb­ne łat­ki — uru­cha­mia­my ponow­nie kom­pu­ter. Goto­we! Pro­ces svchost.exe nie powi­nien już powo­do­wać pro­ble­mów.

PODSUMOWANIE

Jeśli pro­ces svchost.exe powo­du­je pro­ble­my war­to szyb­ko zli­kwi­do­wać pro­blem, aby nie nara­zić kom­pu­te­ra na zbyt wol­ne dzia­ła­nie. Pora­da jest pro­sta i z pew­no­ścią począt­ku­ją­cy użyt­kow­ni­cy kom­pu­te­ra sobie pora­dzą.

By | 2016-11-26T10:07:37+00:00 Kwiecień 23rd, 2011|Categories: News, windows|Tags: , , , , , |6 komentarzy

6 komentarzy

  1. Marcin 30/04/2011 w 10:44- Odpowiedz

    Witam. Mam pro­blem z cpu. Przy uru­cha­mia­niu sys­te­mu mam ok.70 – 100%cpu. Tyl­ko przy uru­cho­mio­nej Ope­rze od 30 – 80%CPU.Chcę zasto­so­wać się do tej porady.Czy jeśli mam Vistę 32bit, też mam pobrać łat­kę z punk­tu 8.)na XP Win­dow­sXP-KB927891-v3-x86-ENU czy inną?

    • NameR> 13/12/2013 w 15:09- Odpowiedz

      I ja mia­łem ten pro­blem. 98% CPU i by wogó­le jakoś ruszyć z miej­sca trze­ba było zaczy­nać od pane­lu pro­ce­sów. Ale już mam to w dupie. Zwy­czaj­nie wyłą­czy­łem aktu­ali­za­cje auto­ma­tycz­ne i zapo­rę Win­dy bo i tak są do nicze­go. Pro­sta zasa­da. Im mniej pro­ce­sów przy star­cie sys­te­mu > tym lepiej i zdro­wiej dla sys­te­mu. Zamiast szu­kać łat i kom­bi­no­wać zde­cy­do­wa­nie pro­ściej powy­łą­czać wszyst­ko co nam nor­mal­nie nie jest potrzeb­ne. A aktu­ali­za­cje są publi­ko­wa­ne na stro­nach win­dy i robi się to wte­dy kie­dy czło­wiek ma czas, a nie wte­dy gdy Micro­soft sobie przy­po­mni o naszym ist­nie­niu ;-) Jesz­cze tyl­ko muszę się pozbyć tej cho­ler­nej iko­ny z tray’a w ształ­cie czer­wo­nej tar­czy. Strasz­nie mnie wpie­nia…

  2. Artus2007 30/04/2011 w 13:09- Odpowiedz

    Niech kole­ga spraw­dzi, czy na stro­nie MS jest taka łat­ka do Visty, bo pora­da przed­sta­wia spo­sób dla XP. Jeśli znaj­dziesz odpo­wied­nie łat­ki to wszyst­ko powin­no iść dalej tak samo.

  3. carramba 18/10/2011 w 23:15- Odpowiedz

    mam pro­blem ze zna­le­zie­niem tego w tej wyświe­tla­nej stro­nie, spo­ro tam tego i nigdzie tego nie­ma pro­sze o podpowiedź.Dwa pli­ki mam pierw­szy i trze­ci a dru­gi nie.

  4. koles 12/12/2012 w 12:39- Odpowiedz

    Wiatm, mam taki sam pro­blem na win7. Jest jakiś spo­sób żeby to roz­wią­zać?

  5. czarek 08/01/2016 w 19:31- Odpowiedz

    Dzię­ki za pomoc, to “svchost.exe” doku­cza­ło mi od ponad roku. Po wyko­na­niu Two­ich porad naresz­cie mam spo­kój. Pozdra­wiam.

Zostaw komentarz